TSH lagging TS

Support forum for the Trainsim Helper program by Havner

Moderator: Havner

TSH lagging TS

Unread postby JPS2K5 » Fri Oct 13, 2017 2:17 am

Problem:

Since about 4 weeks give or take, I have the problem that TSH is severely lagging TS. From what I can tell it's the polling of the USB devices/joysticks. Conclusions and possible reasons:

- It might have started occurring after I built my new PC (i9 7900x).
- It might have happened after some windows update
- It might have happened after some TS update (was there one in the last few weeks?)

- It does not matter what or wich devices I have plugged in (but when my Saitek panels are still plugged in they do start flashing on/off after TSH is started).
- It does not matter if I take my own TSH config or the default one fresh out of the ZIP.

By severely lagging I do mean that I always managed to get a steady 60 fps, perhaps a very occassional drop to 40-50. Now it can drop down to 20 and stay there for 30 secs, and even give longframes. I am in the process of copying my ~150GB folder to a backup location to try a fresh install, but I'm not hopefull that will change anything. Meanwhile I would appreciate some feedback to see if anyone else has noticed any changes.
JPS2K5
 
Posts: 39
Joined: Sat Aug 27, 2016 5:19 am

Re: TSH lagging TS

Unread postby Havner » Mon Oct 16, 2017 3:13 pm

Sorry, I've never heard of anybody that experienced it nor have I myself. The input/usb code I use is taken from an example written by Microsoft so I don't suppose there are any major design issues with the way it's handling input events.

The blinking though might indicate that the device is constantly reconnecting for some reason. Other than that I have no idea *!sad!*
User avatar
Havner
 
Posts: 56
Joined: Wed Sep 10, 2014 8:46 pm

Re: TSH lagging TS

Unread postby JPS2K5 » Sat Dec 02, 2017 3:24 pm

Well, I went as far as replacing my i9-7900x and getting a Z370 mainboard with an I7-8700K to get this sorted. No joy !*hp*!

I have done a fresh install of windows and everything else. It looks like the lag starts happening after the latest major windows update (wich isn't in my default installation media).
I can rule out the newer chipsets on the mainboard now I guess, since Z370 is nothing more than Z270 with a few things added/altered.

The blinking is gone but the lag stays. So that seemed to be unrelated.

No power management on USB devices. No game bar or other useless stuff in windows enabled.

Sorry, just rambling here.. With the money I've thrown at it, I was hoping to get this resolved. I won't play with 20fps, and I won't play with a keyboard. Gonna do one more fresh windows install to make sure that the 3rd time it will also start lagging after updating, and then give up I guess **!!bang!!**
JPS2K5
 
Posts: 39
Joined: Sat Aug 27, 2016 5:19 am

Re: TSH lagging TS

Unread postby Havner » Sat Dec 02, 2017 4:22 pm

Out of curiosity, what Windows are you using? I've never went beyond W7, so I'm completely unsure how e.g. W10 is going to behave. Lots of things have changed there, no idea.

Are you 100% sure it's the USB?

Have you tried going normal fullscreen in TS effectively ignoring the overlay?
Or running with the -j option that causes TSH not to initialize the input?
User avatar
Havner
 
Posts: 56
Joined: Wed Sep 10, 2014 8:46 pm

Re: TSH lagging TS

Unread postby JPS2K5 » Fri Dec 08, 2017 3:52 am

Thank you for your curiosity.

I'm using Windows 10, latest release, 64 bit. When I go to fullscreen, same thing happens. with the -j option, also same thing. If I go to the task manager while TS is running and quit TSH, fps jumps up to steady 60. If I start TSH again, drops/fluctuates to 20....
JPS2K5
 
Posts: 39
Joined: Sat Aug 27, 2016 5:19 am

Re: TSH lagging TS

Unread postby Havner » Sun Dec 10, 2017 12:19 pm

If it happens with -j it's not joystick, as it's not being polled then. The only thing I can come up with is that W10 doesn't like the transparent window TSH is making for some reason. Other then that, sorry, I have no idea :-(
User avatar
Havner
 
Posts: 56
Joined: Wed Sep 10, 2014 8:46 pm

Re: TSH lagging TS

Unread postby JPS2K5 » Tue Dec 26, 2017 4:11 am

Hi,

I just wanted to let you know that after another new install, I can say for sure it must be the overlay, together with any Windows 10 higher than version 1607.

I did another fresh install. My installation version of windows is 1607. Everything worked. Then I get an update to 1703. Here the drops to 20fps come in. Same thing with 1709.
Now, I was ready to give up on this whole thing and order and try a Raildriver (for the 2nd time), when I noticed that over at UKTS they also have an interface program that apparently since a month or two also supports joysticks. So I tried that. It works 100% ok if I turn the overlay off. With the overlay on, I get the same drops to 20fps.'I have no idea why going full screen didn't resolve my problem with TSH, but yes, disabling the overlay on the other program does the trick.

Just wanted to let you know, in case you'd like to look into it some more. Obviously for me, the pressure is off :)
JPS2K5
 
Posts: 39
Joined: Sat Aug 27, 2016 5:19 am

Re: TSH lagging TS

Unread postby Havner » Fri Jan 05, 2018 8:00 am

You mean the program by CobraOne?
User avatar
Havner
 
Posts: 56
Joined: Wed Sep 10, 2014 8:46 pm


Return to TrainSim Helper

Who is online

Users browsing this forum: No registered users and 2 guests